E04

Is there an E04 error code displaying on your Lay-Z-Spa pump? This means your Lay-Z-Spa pump is experiencing a heating issue.

We recommend following these troubleshooting steps to get back in your Lay-Z-Spa in no time.

Step 1 - Check if pump is overheating:

Please follow these steps to resolve this:

  1. Turn the power to the pump off and remove the plug from the socket.
  2. Remove the pump from the liner by placing the stopper caps on the inside over the debris screens.
  3. Take the spa pump off and place this in a cool area or inside.
  4. Once this has cooled down for 1 to 2 hours, reattach the pump to the liner and complete the full reset.

Step 2 - Check if the pump's thermometer reading incorrect:

If the above does not solve this, the thermometer reading could be incorrect.

Please compete the full thermal reset steps to check this:

  1. Turn Pump On.
  2. Press Test – either on the PRCD or on the pump screen display.
  3. Turn plug off and remove from socket.
  4. Plug back in and turn on.
  5. On the PRCD (black box) press: Reset → Test → Reset.
  6. Hold down the On / Off button on the pump for 5 seconds.
  7. Press thermal reset button (See picture for location of reset button on the final page).
  8. Press heater button – pump should be working with no error codes.

You can also view our video with the Thermal Reset steps here:

Step 3 - Is the spa in direct sunlight?

Ensure the spa is out of direct sunlight and do not use the pump in over 40°c.

If you experience this error code make sure the full thermal reset steps listed above are completed before the pump is used again.

If the following steps provided above, do not resolve the issue please contact our Customer Care team below.