E08

Is there an E08 error code displaying on your Lay-Z-Spa pump? This means your Lay-Z-Spa pump is experiencing a power supply issue.

We recommend following these troubleshooting steps to get back in your Lay-Z-Spa in no time.

Step 1 - Complete thermal reset:

The pump will require a full thermal reset occasionally during the use of the spa. Please follow these steps making sure 10 seconds is left between each step:

  1. Turn Pump On
  2. Press Test – either on the PRCD or on the pump screen display
  3. Turn plug off and remove from socket
  4. Plug back in and turn on
  5. On the PRCD (black box) press: Reset → Test → Reset.
  6. Hold down the On / Off button on the pump for 5 seconds.
  7. Press thermal reset button (See picture for location of reset button on the final page)
  8. Press heater button – pump should be working with no error codes.

Here’s a link to our thermal reset video:

Step 2 - Check power supply:

Lay-Z-Spa pumps have to be plugged directly into a grounded mains supply. Please see the checklist below for further information:

Where is the item plugged into?

•            Is the pump plugged into a single of double socket?

•            Is the pump being used with an extension lead?

•            Are there any other items plugged into the same socket?

•            Is the plug socket outside? If so, is the socket waterproof?

•            How old is the plug socket?

•            Is the plug socket connected directly into the mains or is it a spur?

•            Are there any other household items tripping?

•            When was the last time the socket was tested by an electrician?

If the following steps provided above, do not resolve the issue please contact our Customer Care team below.