Electrical Issues

Here is a Troubleshooting Guide which should resolve all electrical issues experienced with all AirJet and HydroJet Spas.

Possible causes of this may include:

  • If the spa is plugged into an extension lead
  • If the grounding in the socket being used is incorrect
  • There is a problem with the electric set up in the house
  • There may be another appliance causing a problem in the circuit
  • Overloading the circuit

Are you experiencing tripping electrics?

We recommend following these troubleshooting steps to get back in your Lay-Z-Spa in no time.

Step 1 - Try a different socket:
  1. Turn the pump off using the On/Off power button on the pump display. Remove the plug from the socket.
  2. Plug the spa pump in to another socket (preferably inside your home if you have been trying with an outdoor socket)
  3. Switch the pump on and press the reset/test button on the cable. Press the power button on the pump display screen.

Step 2 - Check this electrical checklist:

•            Where is the item plugged into?

•            Is the pump plugged into a single of double socket?

•            Is the pump being used with an extension lead?

•            Are there any other items plugged into the same socket?

•            Is the plug socket outside? If so, is the socket waterproof?

•            How old is the plug socket?

•            Is the plug socket connected directly into the mains or is it a spur?

•            Are there any other household items tripping? Is this is at the same time everyday?

•            When was the last time the socket was tested by an electrician?

Step 3 - Make sure the socket isn't overloaded/ there isn't a problem with the circuit:

If you find the pump is shutting off or tripping when you press the heat button, we suggest checking the circuit being used.

  • Please unplug other items on the same circuit for example fridge/freezers, washing machines, kettles as all of these items also require a lot of energy.
  • If the pump is plugged in to a double socket with another appliance or extension lead, please remove this and try your pump again.
  • Are other items being switched on when the pump shuts off? This could be a case of overloading or another item on the circuit is causing the issue.

The Lay-Z-Spa pump will draw up to 2850W when heating + bubbles are switched on.

Step 4 - Check if you are experiencing no power to the pump:

Are you experiencing no power to the pump?

We recommend trying the pump power reset steps to try and resolve this and ensure you get back in your Lay-Z-Spa in no time:

  1. Turn Pump On
  2. Press Test – either on the PRCD or on the pump screen display
  3. Turn plug off and remove from socket
  4. Plug back in and turn on
  5. On the PRCD (black box) press: Reset → Test → Reset.
  6. Hold down the On / Off button on the pump for 5 seconds.

If these steps do not resolve the issue and you need to contact us, we may provide a plug tester in order to check the status of the plug socket as part of our investigation. The PRCD shows “In: 16A” as this is the maximum amperage the RCD can handle before tripping. The spa does not draw 16A of load. There is also a 13A fuse in the plug, so if the load was 16A this would trip every time the spa is used.

We do not recommend that you plug your Lay-Z-Spa into an extension lead.

If the following steps provided above, do not resolve the issue please contact our Customer Care team below.