Noisy pump

Here is a Troubleshooting Guide and instruction manual which should resolve all issues experienced with all AirJet and HydroJet spas which have become noisy or overly loud.

The issue may be caused by what the spa pump is sat upon.

We would advise to check and ensure the following steps or guidelines are followed on the set up for a Lay-Z-Spa pump:

  • Ensure the pump is located on a flat, hard surface
  • Please ensure foam protection mats are used under the pump
  • Make sure the pump is located away from any walls.
  • Do not place the pump or spa on any gravel or sharp surfaces.
  • Ensure that the pump is not enclosed or boxed in.

Once you have checked these recommendations and are still experiencing the issue please follow these troubleshooting steps:

Step 1 - Check water sensor:

To solve this issue please follow these steps:

  1. Turn the pump off using the On/Off power button on the pump display.
  2. Move to the power supply, turn the power off and remove this from the socket.
  3. Remove the pump from the spa liner by placing the stopper caps within the spa over the debris screens.
  4. Strike the pump firmly on the side.
  5. This should move the sensor into the correct position.
  6. Plug the spa back in and reset the pump.

Step 2 - Check for debris build up:

The pump may become noisy if there is debris stuck or the washers have moved inside the pump

To solve this issue please follow these backwash steps:

  1. Turn the pump off using the On/Off power button on the pump display.
  2. Move to the power supply, turn the power off and remove this from the socket.
  3. Remove the pump from the spa liner by placing the stopper caps within the spa over the debris screens.
  4. Unscrew the 3 couplings A, B and C.
  5. Using a hosepipe, flush water in through the pumps B pipe which should then come out the C.
  6. Complete this for about, 2 to 3 minutes.
  7. Once this has been completed, switch the water flow from in through the C and out again through the B.
  8. Once you have completed this for roughly 2 to 3 minutes re-attach the pump to the liner.

View our backwash video which will take you through these steps here:

Please note, when going though the above troubleshooting steps do not hit the pump on either the top or bottom.

If the steps provided above, do not resolve the issue please contact our Customer Care team below.